What versions of Visual Studio are supported?

All versions of Visual Studio of 2017, 2015, 2013, 2012, 2010, 2008, 2005 C++ compiler are supported, Visual Studio Express version and Community version are also supported.

If a DLL is compiled and dynamically linked with the run-time library of certain version of Visual Studio C++ compiler, for example, Visual Studio 2017, Visual Studio 2015, Visual Studio 2013, Visual Studio 2012, Visual Studio 2010, Visual Studio 2008, Visual Studio 2005, etc, any application using the DLL must be linked to the same version of Visual Studio run-time to use any C++ STL class and C++ functions. All versions of Visual Studio of 2017, 2015, 2013, 2012, 2010, 2008, 2005 C++ compiler are supported.

The C++ run-time is automatically detected by xInterop C++ .NET Bridge, and the generated C# .NET assembly will be referencing the corresponding .NET StdLib automatically.


← Faqs
Translate »